Large Open Source Software Archive for AIX

We have moved to a new VM. If you experience any unexpected issue, please warn us through the Contact page.

This site contains a collection of open source and GNU (R) software packages built for AIX 5L, AIX 6, and AIX 7.
Some of these packages (like GCC and GCC-related) have one package per AIX version but in most cases, a package built for an AIX release (5.3 or 6.1) will also run on upper releases. We now build mainly on AIX 6.1, no more on AIX 5.3 .
Packages for AIX N do not run on lower versions (e.g. packages for AIX 7.1 do not run on AIX 6.1 or on 5.3).

The Open Source Packages for AIX will help compiling and packaging Linux applications on AIX systems, developing new applications for AIX using the GNU environment, and running popular software provided in Linux distributions such as:

These packages also provide a set of tools both for Linux appplication developers and Linux system administrators.
All packages are built using the RPM format.

Some open source licenses (such as GPL) require that we also make the source available.
Only sources for packages with licenses requiring source redistribution are found on this site.

2018-May 14th: GCC 8.1.0 with Go v1.10 for AIX 7.2 has been delivered .

2018-April 11th: Update of GCC Go 8.0.1-20180305 with Go v1.10 for AIX 7.1 and 7.2 .

2018-January 18th: Update of GCC Go 8.0.0-20171205.aix7.2 . Builds Kubernetes/Kubelet/Telegraf/Hyperledger/FileBeat ...

2018-January 17th: A version 0.19.8 of gettext package has been uploaded on BullFreeware. This version was quickly replaced by by gettext project. However, version 0.19.8 introduced new versions of ( and of other .so files that have been abandonned by version . However, we have already built and uploaded several packages (gnupg2, krb5, libgpg, posgresql, python, python3, glib2, gnutls, guile) that now depend on, which is wrong. I plan to upload gettext, without support of 0.19.8 and soon, and I am rebuilding the packages from the above list, with issues. If you encounter the message: "libintl.a( is needed by ..." or "libintl.a( is needed by ...", you have reached the mess. The solution is to put in /opt/freeware/lib/libintl.a both and and (since dependencies are done by RPM based on data in its database rather than looking at the files) you'll have to use --nodeps (only when the last error message is: libintl.a( is needed by ...". Example:
cd /tmp ; mkdir -p opt/freeware/lib/
rpm2cpio gettext-0.19.8-1.aix6.1.ppc.rpm | /opt/freeware/bin/cpio -iv opt/freeware/lib/libintl.a
--> opt/freeware/lib/libintl.a
# ar xv opt/freeware/lib/libintl.a
x -
# ar q /opt/freeware/lib/libintl.a
# ar -X64 xv opt/freeware/lib/libintl.a
x -
# ar -X64 q /opt/freeware/lib/libintl.a
So, file /opt/freeware/lib/libintl.a contains file . However RPM relies only on its information stored in its DataBasePM.
So, we still have the error message:
# rpm -i postgresql-10.1-2.aix7.2.ppc.rpm
error: Failed dependencies:
libintl.a( is needed by postgresql-10.1-2.ppc
You have to do:
# rpm -i --nodeps postgresql-10.1-2.aix7.2.ppc.rpm

I'm working on fixing this mess.

2018-January 17th: We are focused on PostgreSQL and GCC 8 (with Go v1.10) now.

2018-January 17th: Snapshot RPMs for GCC 8 with Go are available at: GCC Go for AIX 7.2 . They are not maintained till GCC 8 is officially available. For now, it is Go v1.9 .

2016-August 18th: Up to now, we tried to use the XLC compiler (v12 or v13) rather than GCC (4.8.4 or higher) for building the packages. Starting from now, we'll try to use GCC before using XLC, IFF the quality is the same for sure. And some packages do require GCC or XLC.

2016-August 18th: How to proceed when the package you need depends on GCC libs and when you plan to install on AIX 7.1 (or 7.2) and not on AIX 6.1 ?!?
The tool which provides a list of the dependent packages to be downloaded (one by one or by means of the .zip file) does help a lot but is far not perfect. So, if you want to install a package on a AIX 7.1 or 7.2 machine, you must take all the required packages that are available for a version of AIX <= 7.1 (in general : AIX 6.1) EXCEPT for the GCC and GCC-related packages (libstdc++, libgcc, ...) which MUST have the version of your machine (AIX 7.1 or 7.2). This is due to the fact that the GCC compiler depends on the include .h files and on some lib*.a files delivered on the version of AIX and that they MUST be of the same AIX version than the machine you want to install them on.
Example: Let say you want to install "git", which depends on many other packages including libgcc and libstdc++. For sure, you do not need the GCC compiler but, when we built git, the build process made use of some useful parts of libgcc and libstdc++. So, if you want to install "git" git-2.8.2-1.aix6.1.ppc.rpm (built on AIX 6.1) on a AIX 7.1 machine, you need : libstdc++-6.1.0-5.aix7.1.ppc.rpm and libgcc-6.1.0-5.aix7.1.ppc.rpm rather than the aix6.1 version proposed by our tool to be downloaded.
We hope to be able to improve this by adding some feature to our web-site, some day.

Also, please note that our tool nearly always proposes the LAST version (on AIX 6.1) of the dependent packages (except if package contains "Requires" instructions for older versions). Since we manage compatibility with older versions of many of our packages, this last version should contain old libs (.so files in .a files) that are required by older versions of other packages installed on your machine, so that you should not face an issue when 2 tools require 2 different versions of a common dependency. In case that occurs, please warn us.

2016-June 8th: More statistics are available at: New Statistics.

GCC & 64bit WARNING:

2016-June 8th: If you use GCC AND 64bits, you should move to last release of each version of GCC (when available):
GCC 6.1.0-5 - GCC 5.4.0-2 - GCC 4.8.5-5 - GCC 4.8.4-6

(Though we try to use IBM XLC first, we also use GCC, mainly version 4.8.4).


2016-September 22th: OpenSSL: New versions 1.1.0a, 1.0.2i, 1.0.1u are now available.

2016-August 31th: OpenSSL: New version 1.1.0 is now available.

2016-May 10th: OpenSSL security vulnerability. Use OpenSSL packages versions 1.0.1t and 1.0.2h.
See: OpenSSL Security Advisory [3rd May 2016] .

2016-April 20th: GZIP: New version 1.6-2 . Previous version deleted /usr/bin/uncompress from AIX LPP, thus creating an issue at AIX reboot. Update !

2016-April 12th: SAMBA: New security version 4.3.8 . See: Release Notes for Samba 4.3.8 .

2016-March 1st: OpenSSL security vulnerability with SSLv2 and EXPORT. Use OpenSSL packages versions 1.0.1s and 1.0.2g.
See: CVE-2016-0800 . See: OpenSSL 2016-03-01 .
Please update with: latest version 1.0.1s , and: latest version 1.0.2g .

2016-February : OpenSSL packages versions 1.0.1 upto 1.0.1q and 1.0.2 upto 1.0.2e contain an OpenSSL security vulnerability.
See: CVE Mentioned in Article about Two OpenSSL Vulnerabilities on InfoWorld .
If you have downloaded one of these versions, please update with: latest version 1.0.1r , and: latest version 1.0.2f .

OpenSSL packages versions 1.0.1 upto 1.0.1f contain an OpenSSL security vulnerability.
See: CVE-2014-0160 .
If you have downloaded one of these versions, please update with the latest version 1.0.1g .

Issue affecting OpenSSL versions 1.0.2c, 1.0.2b, 1.0.1n and 1.0.1o :
See: CVE-2015-1793 .
OpenSSL 1.0.2b/1.0.2c users should upgrade to 1.0.2d .
OpenSSL 1.0.1n/1.0.1o users should upgrade to 1.0.1p .

Bash package versions 4.2-7 has been upgraded to 4.2-9 including bash shell vulnerability patches .
See: CVE-2014-6271 .
CVE-2014-7169 .